Error on first attempted login

Error on first attempted login

Postby sjarmstrs » Tue Dec 05, 2017 11:42 pm

nubuilder4_errors.jpg
nubuilder4 errors
nubuilder4_errors.jpg (91.15 KiB) Viewed 125 times


Hi,

I am a long-time nuBuilder Pro user.

I have installed nuBuilderForte as directed in the help pages, unzipping the SW to a folder on my web server. I have a BitNami WAMP stack installed and working and I have imported the nubuilder4 SQL into a new database. I have also set up the nuconfig.php file with the relevant entries. However, when I try to hit the index.php file from my web browser, I get a blank screen and the browser console shows the errors in the attached screenshot.

Any guidance you can provide to get up and running would be greatly appreciated.

Simon.
sjarmstrs
 
Posts: 1
Joined: Tue Dec 05, 2017 11:31 pm

Re: Error on first attempted login

Postby cypherinfo » Sat Dec 09, 2017 8:43 pm

I had the same issue; I found that my error was the wrong password in $nuConfigDBPassword. I'd suggest you to verify those pices of information.
cypherinfo
 
Posts: 99
Joined: Fri Feb 19, 2010 2:12 am

Re: Error on first attempted login

Postby nac » Wed Dec 13, 2017 8:20 am

Hello,

I am very new to nuBuilder (and PHP) and I too am having problems with login, although I think my problem is a bit different. Having followed the installation instructions at http://wiki.nubuilder.net/nubuilderfort ... .php/Setup, I was able to use the globeadmin account to create a table and a form and it all works perfectly via the 'User home' button. However if I try to login with a user account (either the built-in 'nu' or one I create myself) then I always get an 'invalid login' error. I have changed the password by visiting the Home ► User ► User form but this makes no difference. Incidentally, whenever I visit this form, I always have to re-enter the password twice as an error message appears when I try to save the form if I don't.

The browser console shows the following as soon as I click the 'log in' button.

nb login problem console.png
nb login problem console.png (26.73 KiB) Viewed 62 times


BTW, I uploaded my nuBuilder files and tables to a different server and found the same problem. So at this point I am truly stumped.
No doubt I am missing something very obvious; any pointers as to what it may be would be very welcome.

Neil
nac
 
Posts: 2
Joined: Wed Dec 13, 2017 7:58 am

Re: Error on first attempted login

Postby toms » Wed Dec 13, 2017 1:38 pm

My obeservations so far/steps to replicate the problem:

- I created a new user X
- the login works just fine with that newly created user X
- then I changed the password for user X
- the login fails now with the new password. As I can see in the db table, the password has been changed.
- I also see that error msg "POST https://xxx/nuBuilder4/nuapi.php 403 (Forbidden)" in the console and nuBuilder shows a "Invalid login." message.
- Now if I set the initial password again, the login works again
- I verifyed the passwords in the db with a MD5-decrypter. They are all correct.
- This issue even exists in V3.
Attachments
img_err.png
img_err.png (30.53 KiB) Viewed 60 times
toms
 
Posts: 33
Joined: Wed Nov 08, 2017 8:57 pm

Re: Error on first attempted login

Postby nac » Thu Dec 14, 2017 4:05 am

Hello toms,

Thanks for looking into this; and I am really glad that you were able to replicate the issue. I am not sure where to go next but I have been able to create a couple of working accounts so should be OK for the moment. As this was an issue in version 3, does it mean it unlikely to be addressed? I guess it has not created issues for anyone else.

Is this behaviour related to the issue I raised about the need to re-enter the password whenever the 'user details' form is updated? Once a user is created, I assume that the user him/herself will be able to modify all the details (inc. password) except the Login Name (permanent) and the Access Level (global admin only). The rest of the user profile should be accessible to the user to change. Is there a standard form for this? Sorry for so many questions - I really should read the documentation!

Overall, nuBuilder seems to be very good indeed; I am very impressed. I have been using A2N.accdb to migrate MS-Access tables but am not sure if the statements that populate the zzz% tables with forms and reports are compatible with version 4.

Thanks again for your interest and help.

Neil
nac
 
Posts: 2
Joined: Wed Dec 13, 2017 7:58 am

Re: Error on first attempted login

Postby toms » Fri Dec 15, 2017 3:30 pm

nac wrote:Thanks for looking into this; and I am really glad that you were able to replicate the issue. I am not sure where to go next but I have been able to create a couple of working accounts so should be OK for the moment. As this was an issue in version 3, does it mean it unlikely to be addressed? I guess it has not created issues for anyone else.


I pulled the latest code from github and I'm able to log in after changing a user's password :D

nac wrote: Once a user is created, I assume that the user him/herself will be able to modify all the details (inc. password) except the Login Name (permanent) and the Access Level (global admin only). The rest of the user profile should be accessible to the user to change. Is there a standard form for this? Sorry for so many questions - I really should read the documentation!


I haven't seen an inbuilt form for that but this could be achieved by cloning the password form (or replicating parts of it) leaving just an old/new password field to allow a user to change his own password.
toms
 
Posts: 33
Joined: Wed Nov 08, 2017 8:57 pm

Re: Error on first attempted login

Postby pierrot » Sat Dec 16, 2017 12:43 am

Funny thing, I can login only when user=password :)
pierrot
 
Posts: 7
Joined: Thu Dec 14, 2017 8:21 pm

Re: Error on first attempted login

Postby admin » Sat Dec 16, 2017 1:28 am

pierrot,

You were right!

All fixed now.

Steven
admin
Site Admin
 
Posts: 1881
Joined: Mon Jun 15, 2009 9:53 am


Return to General



cron