Newbie question: why do lookups not work for me?

Newbie question: why do lookups not work for me?

Postby Tukcedo » Tue Apr 26, 2016 7:40 pm

Dear nuBuilders,

I discovered nuBuilder by chance a few days ago and I would like to use it to create a Read-Only user web application for a bunch of MySQL databases we're running. However, for the life of me I can't get lookup or subforms to work properly so I would appreciate some pointers. The tables "products" and "suppliers" both have an auto-increment "id" as their PK and they can be linked by a varchar, "suppliernumber" in products and "relationnumber" in suppliers. I have created a simple form for both tables. Then in the products form I would like to show the supplier's name and a link to the form. I've tried a 100 times in the Form Wizard but here's the strange thing: the suppliernumber now shows a completely unrelated number that is NOWHERE in that record and when I open the suppliers form through that lookup it just shows the grid, not an edit form. Incidentally, I tried it with subform too but that just isn't what I'm looking for I don't think.

I'm totally comfortable with SQL but I just haven't found a place in the menu system where I can adjust the underlying queries (because I feel that is where the problem lies). If necessary I'll be more than happy to do that directly in MySQL, but hopefully it can be done through the system?

Another question: how can I best implement applications of different databases but for the same user(name)? Install them in parallel directories under the web server root?
Tukcedo
 
Posts: 2
Joined: Tue Apr 26, 2016 7:20 pm

Re: Newbie question: why do lookups not work for me?

Postby admin » Thu May 05, 2016 5:00 pm

Tukcedo,

The unrelated record you are talking about is the Foreign Key used to link to the correct field in the other table. You need to join both tables with SQL then you will be able to view the correct field.

BTW have you watched any of the tutorials? https://www.youtube.com/watch?v=xLY3L1K_vqE&list=PLbyPJ4RnFyOpQy8XsNELQu8AJK7Eetc4R

Steven
admin
Site Admin
 
Posts: 3234
Joined: Mon Jun 15, 2009 9:53 am

Re: Newbie question: why do lookups not work for me?

Postby Tukcedo » Fri May 06, 2016 6:29 am

Hi Steven,

I was relying on the documentation on the web site that really only describes what's on the various forms, rather than how to accomplish certain tasks. I'll check out those vids, thx for the tip!

Mich.
Tukcedo
 
Posts: 2
Joined: Tue Apr 26, 2016 7:20 pm

Re: Newbie question: why do lookups not work for me?

Postby admin » Wed May 18, 2016 3:33 pm

OK
admin
Site Admin
 
Posts: 3234
Joined: Mon Jun 15, 2009 9:53 am


Return to General



cron