Search problem SOLVED!

Search problem SOLVED!

Postby kokarman » Wed Jul 13, 2016 11:35 pm

Quite so!L ike in many other occasions formulating the problem is the solution.

Hi,

When I search for specific content in records of a browse form the search string is coloured red in all records with that string but the records are not filtered.
It seems to me that that the search command normally in the background adds a 'where' clause to the form query but that in this case the query is corrupted.
It is just in one form, all other forms are searchable as expected.
Has someone experienced the same?
Thanks for any hint.
Attachments
search.jpg
search.jpg (24.5 KiB) Viewed 5538 times
kokarman
 
Posts: 12
Joined: Wed Apr 13, 2016 9:58 pm

Re: Search problem SOLVED!

Postby admin » Thu Jul 14, 2016 4:30 pm

kokarman,

If your Form's SQL has a WHERE statement, put brackets around it..

eg..

SELECT * FROM customer WHERE (name = 'Bob' OR name = 'Jim')

Steven
admin
Site Admin
 
Posts: 3211
Joined: Mon Jun 15, 2009 9:53 am

Re: Search problem SOLVED!

Postby kokarman » Sun Jul 17, 2016 3:43 pm

Hi Steven,

By cutting the WHERE clause everything was fine again.
So I was experimenting with the code and I was very close...
This saves me time.
Thanks a lot!

Ko
kokarman
 
Posts: 12
Joined: Wed Apr 13, 2016 9:58 pm

Re: Search problem SOLVED!

Postby admin » Thu Aug 04, 2016 9:59 am

.
admin
Site Admin
 
Posts: 3211
Joined: Mon Jun 15, 2009 9:53 am

Re: Search problem SOLVED!

Postby SteveHolland » Wed Aug 24, 2016 4:19 pm

Good work and program looks promising. What stage are you in now? Today I run a working demo of NuBuilder, adapted for a car-fleet company in Rotterdam. It might be interesting to exchange cards with you... Kind regards, Steven Hoogslag.
SteveHolland
 
Posts: 8
Joined: Tue Jun 28, 2016 7:39 pm
Location: Rotterdam, The Netherlands

Re: Search problem SOLVED!

Postby admin » Tue Aug 30, 2016 10:24 am

.
admin
Site Admin
 
Posts: 3211
Joined: Mon Jun 15, 2009 9:53 am


Return to General