Problem deleting forms

Problem deleting forms

Postby EcoReality » Thu Feb 16, 2017 10:14 am

I accidentally created three forms (using the "Form Wizard") that had identical names.

When I then deleted two of them, the browser via "User Home" button looks strange, and I find I can no longer use the remaining one when I click on it; it claims I have some bad SQL (apparently with just "SELECT" and nothing else).

I have checked the SQL in that form, and it seems to be okay.

There are two other forms that are behaving badly the same way, for the same reason: I created them by accident, and deleted them, but they still show on the "User Home" browser.

What can I do to recover from this situation? I'm not afraid of PHP and SQL; I briefly looked through the "zzzsys" tables for a lone "SELECT", but found nothing.
Attachments
Screenshot  2017-02-15 at 16.15.42.png
Screenshot 2017-02-15 at 16.15.42.png (22.27 KiB) Viewed 664 times
Screenshot  2017-02-15 at 16.41.45.png
Screenshot 2017-02-15 at 16.41.45.png (58.58 KiB) Viewed 664 times
:::: Jan Steinman EcoReality Co-op ::::
EcoReality
 
Posts: 26
Joined: Wed Feb 15, 2017 5:20 pm
Location: Salt Spring Island, British Columbia, Canada

Re: Problem deleting forms

Postby EcoReality » Fri Feb 17, 2017 8:25 am

Okay, figured it out.

If you use the Form Wizard over and over with the same information, it creates a referential integrity problem, where the "Field Name" for the button (like "Surveybtn") is the same for each object, and it appears this field should be unique.

I simply appended a character to make these fields unique, then I was able to delete them.

BUG: This column probably needs to be indexed UNIQUE to keep this from happening.
:::: Jan Steinman EcoReality Co-op ::::
EcoReality
 
Posts: 26
Joined: Wed Feb 15, 2017 5:20 pm
Location: Salt Spring Island, British Columbia, Canada

Re: Problem deleting forms

Postby admin » Sat Feb 25, 2017 8:53 am

.
admin
Site Admin
 
Posts: 3215
Joined: Mon Jun 15, 2009 9:53 am


Return to General