Page 1 of 1

wrong user or password

PostPosted: Fri Feb 19, 2016 9:00 pm
by boingemar
I have nuBuilderPro 3 with wamp apache 2.4.9 and php 5.5.12 mariadb (mysql) 10.10.17. (W7 64-bit 64-bit WAMP et c)

First I got errors about mysql_connect() and I changed the nuinstall_lib.php in 17? places and put a @ in front of all old mysql interface functions. After that the http://127.0.01/nubuilder/nuinstall.php went ok, however I cannot login to the database! I get "Your username or password was incorrect".

I have verified that the mariadb root user can be connected to, either via localhost or 127.0.0.1 from MySQL Workbench 6.2, I even have another user that grants me access from another computer to the database, via 'standard' security.
I did a complete reinstall of nuBuilderPro keeping only the nuinstall-lib.php and the config.php, with the same results.

SO, my questions are raised along these lines:
A) Does nuBuilderPro need SSL?
B) Does it test for mariadb version 10 and rejects for that reason?
what else can go wrong?

This is an evaluation only of nuBuilderPro, and I need to see how it really works, and if I can use this for pro bono project (where they don't have a real windows server version). and uses hosts files.

Thanks for any input on this!

Re: wrong user or password

PostPosted: Sun Feb 21, 2016 4:33 am
by boingemar
I definately think it has to do something about the mysql api used. I did test Xataface and it had an option for choosing between mysql_ and mysqli and that worked although I did not like that Xataface interface. Maybe I'l rewrite the Nuibuilder pro files to support Mysqli, just to check it out - however, meanwhile I'll keep my eyes open for alternatives...

Re: wrong user or password

PostPosted: Wed May 18, 2016 4:07 pm
by admin
boingemar,

To answer your questions..

A)No.
B)No.

Steven