problem installation

problem installation

Postby rafaelsainz » Sun Aug 07, 2016 3:44 am

good day i triing to install i have followed all the steps on https://www.nubuilder.net/downloads.php but when i try to open http://127.0.0.1/nubuilder/nuinstall.php i get error 500 on webpage unzip the files again but no luck any thoghts will be appreciated.
rafaelsainz
 
Posts: 2
Joined: Sun Aug 07, 2016 3:34 am

Re: problem installation

Postby shane » Mon Aug 08, 2016 11:14 am

the only way to debug 500 errors is to check your web server logs to see the reasons for the error.
shane
 
Posts: 100
Joined: Mon Jun 15, 2009 5:34 pm

Re: problem installation

Postby rafaelsainz » Fri Aug 26, 2016 3:50 am

thanks for your help now i checked the log and it shows the following
[Thu Aug 25 13:12:27.095859 2016] [:error] [pid 2092:tid 916] [client 127.0.0.1:49326] PHP Fatal error: Call to undefined function mysql_connect() in C:\\Apache24\\htdocs\\nubuilder\\nuinstall_lib.php on line 52

i assume that it could be because the config file is not right or unspecified information but i checked and i placed my user name and password as well as the database name wich im sure is correct will appreciate your help.
rafaelsainz
 
Posts: 2
Joined: Sun Aug 07, 2016 3:34 am

Re: problem installation

Postby shane » Fri Aug 26, 2016 3:58 pm

your version of php does not have php complied into it.
shane
 
Posts: 100
Joined: Mon Jun 15, 2009 5:34 pm

Re: problem installation

Postby nick123 » Mon Sep 05, 2016 1:08 pm

Hi Shane,

I am getting the same error during installation. I am using Xampp v 7.0.9 which runs PHP 7.0.9.

From my understanding, mysql_connect() was deprecated in php v5.something, and scrapped all together in v7, which I am assuming is the cause of this problem.

Is there a recommended version of PHP to use? Or another solution? From reading some docs on your website, nubuilder supports php-pdo, however the version i downloaded (https://github.com/nuSoftware/nuBuilder ... master.zip) uses mysql_connect, and I see no way to change this.

If using an older version of PHP is the solution, is this a safe long term strategy, or will older versions become unsupported an insecure?

Or am i completely on the wrong track here?

Sorry, I really only know enough about this stuff to be dangerous.

Thanks
Nick
nick123
 
Posts: 1
Joined: Mon Sep 05, 2016 1:00 pm

Re: problem installation

Postby Malachy47 » Sun Sep 18, 2016 3:42 pm

Same issue here. Error 500. New install on Ubuntu 16.04 using Apache 2.4 , MySQL 5.7 and PHP 7.0 (i.e. the standard repo versions).

The Apache2 error log does indeed point to a problem with my_sql_connect() as shown below;

[Sun Sep 18 07:05:57.748381 2016] [:error] [pid 9365] [client 127.0.0.1:35212] PHP Fatal error:

Uncaught Error: Call to undefined function mysql_connect() in /var/www/html/nubuilder/nuinstall_lib.php:52\nStack trace:\n#0 /var/www/html/nubuilder/nuinstall_lib.php(19): nuinstall->checkDatabaseConnection()\n#1 /var/www/html/nubuilder/nuinstall.php(17): nuinstall->checkInstall()\n#2 {main}\n thrown in /var/www/html/nubuilder/nuinstall_lib.php on line 52
Malachy47
 
Posts: 2
Joined: Sun Sep 18, 2016 2:02 pm

Re: problem installation

Postby admin » Wed Sep 28, 2016 2:55 pm

Malachy47,

Have you followed this?

https://www.nubuilder.net/downloads.php

Steven
admin
Site Admin
 
Posts: 3079
Joined: Mon Jun 15, 2009 9:53 am

Re: problem installation

Postby Malachy47 » Sun Oct 16, 2016 4:05 pm

Hi Steven,

Thank you for taking the time to reply. I have followed the example and the problem I encounter is the warning described here http://php.net/manual/en/function.mysql-connect.php. I wonder could the code verify PHP version before assuming version is < 7.0 and invoke mysqli_connect() when version >= PHP 7?

Thanks,

-- Tom
Malachy47
 
Posts: 2
Joined: Sun Sep 18, 2016 2:02 pm


Return to Installation



cron