Page 1 of 1

Problems with creating objects

PostPosted: Fri Jan 24, 2020 10:55 pm
by Nico
Succesfully instal NuBuilder and connected to my MysQL database on webhost. Ran the SQL script successfully

Trying to create an object, the All tab works alright however the run tab whilst using the search function will not show earlier created form. If manually entered or copied form name in the field run, this is emptied and I am not ably to save the object.

Any clou? thx

Re: Problems with creating objects

PostPosted: Sat Jan 25, 2020 12:21 am
by kev1n
Normally you don't need to run/import the nubuilder4.sql file. nuBuilder will import and run the SQL file automatically when you first log in with the globeadmin login.
Please verify (in phpMyAdmin ) that two views have been created:

zzzzsys_report_data
zzzzsys_run_list

If they do not exist, run this SQL:

Code: Select all
CREATE VIEW `zzzzsys_report_data`  AS  select concat('PROCEDURE:',`zzzzsys_php`.`zzzzsys_php_id`) AS `id`,`zzzzsys_php`.`sph_code` AS `code`,`zzzzsys_php`.`sph_description` AS `description` from `zzzzsys_php` where `zzzzsys_php`.`sph_system` <> '1' and locate('#TABLE_ID#',`zzzzsys_php`.`sph_php`) > '0' union select concat('SQL:',`zzzzsys_select`.`zzzzsys_select_id`) AS `id`,'nuSQL' AS `code`,`zzzzsys_select`.`sse_description` AS `description` from `zzzzsys_select` where `zzzzsys_select`.`sse_system` is null or `zzzzsys_select`.`sse_system` = '' union select concat('TABLE:',`zzzzsys_table`.`zzzzsys_table_id`) AS `id`,'nuTABLE' AS `code`,`zzzzsys_table`.`zzzzsys_table_id` AS `description` from `zzzzsys_table` ;

CREATE VIEW `zzzzsys_run_list`  AS  select `zzzzsys_form`.`zzzzsys_form_id` AS `id`,'Form' AS `run`,`zzzzsys_form`.`sfo_code` AS `code`,`zzzzsys_form`.`sfo_description` AS `description` from `zzzzsys_form` union select `zzzzsys_report`.`zzzzsys_report_id` AS `id`,'Report' AS `run`,`zzzzsys_report`.`sre_code` AS `code`,`zzzzsys_report`.`sre_description` AS `description` from `zzzzsys_report` union select `zzzzsys_php`.`zzzzsys_php_id` AS `id`,'Procedure' AS `run`,`zzzzsys_php`.`sph_code` AS `code`,`zzzzsys_php`.`sph_description` AS `description` from `zzzzsys_php` where `zzzzsys_php`.`sph_system` <> 1 order by `code` ;

Re: Problems with creating objects

PostPosted: Sun Jan 26, 2020 7:43 pm
by Nico
Nothing seemed to work. I have flushed the database and website domain and reinstalled from blank. All tables and views showed up. Will restart my testing job. thx