Browse Screen: No search results

Questions related to using nuBuilder Forte.

Browse Screen: No search results

Postby kev1n » Thu Aug 27, 2020 3:19 am

Hi Steven,

Gerese reported a bug in the Browse Screen.

1. Search for any string on page 1. Result: OK
2. Go to page 2
3. Search again.
4. No results!

You can see that behaviour in any Browse Screen.

browse_search_no_result.gif
browse_search_no_result.gif (870.32 KiB) Viewed 391 times


I figured out that the bug was introduced with this change
kev1n
 
Posts: 1038
Joined: Mon Oct 15, 2018 2:13 am

Re: Browse Screen: No search results

Postby admin » Thu Aug 27, 2020 7:58 am

kev1n,

I have put your changes on Github.

Thanks.

Please test it again.


Steven
admin
Site Admin
 
Posts: 3372
Joined: Mon Jun 15, 2009 9:53 am

Re: Browse Screen: No search results

Postby kev1n » Thu Aug 27, 2020 8:04 am

Thanks for that!
However, gerese just reported a new issue that is caused by the fix.
I'm not sure how to address that.

With the modified "nuSearchAction" function I encounter the following problem:
if the searched word has 2 or more results pages, you cannot go to the second results page.
kev1n
 
Posts: 1038
Joined: Mon Oct 15, 2018 2:13 am

Re: Browse Screen: No search results

Postby admin » Thu Aug 27, 2020 8:38 am

I have reversed those changes.

Steven
admin
Site Admin
 
Posts: 3372
Joined: Mon Jun 15, 2009 9:53 am

Re: Browse Screen: No search results

Postby kev1n » Sat Aug 29, 2020 11:23 am

Steven,

Do you have an idea what could be causing this behaviour?
kev1n
 
Posts: 1038
Joined: Mon Oct 15, 2018 2:13 am

Re: Browse Screen: No search results

Postby gerese » Thu Sep 10, 2020 1:03 am

Hi Steven,
The search function in nuBuilder is very important to me.
I happen to look for a record, but after scrolling through 2 screens I find that it is easier to enter a search word ... but surprise nuBuilder does not find results.
I have attached an example.
Thanks Steven.
Attachments
nuBuilderSearch.gif
nuBuilderSearch.gif (340.2 KiB) Viewed 314 times
nuBuilderForte .... BIG Like !!!
gerese
 
Posts: 45
Joined: Mon Dec 17, 2018 2:43 am

Re: Browse Screen: No search results

Postby admin » Fri Sep 11, 2020 5:38 am

Hello people,

The fix is now on Github.

Please test it.


Steven
admin
Site Admin
 
Posts: 3372
Joined: Mon Jun 15, 2009 9:53 am

Re: Browse Screen: No search results

Postby gerese » Fri Sep 11, 2020 7:08 am

Work now, Steven.
Many thanks :D
nuBuilderForte .... BIG Like !!!
gerese
 
Posts: 45
Joined: Mon Dec 17, 2018 2:43 am

Re: Browse Screen: No search results

Postby admin » Fri Sep 11, 2020 7:20 am

Cool.
admin
Site Admin
 
Posts: 3372
Joined: Mon Jun 15, 2009 9:53 am

Re: Browse Screen: No search results

Postby kev1n » Fri Sep 11, 2020 1:53 pm

There's still an issue when using nuSearchAction() and passing an argument while being on page > 1

1. Add an action button: nuAddActionButton('filterDisplay', 'Show Only Display', 'nuSearchAction("display", "")');
2. Go to any page > 1
3. Hit the action button
4. --> No Results!


View in full screen
filter.gif
filter.gif (799.47 KiB) Viewed 276 times


Edit: If you don't pass a 2nd parameter, it works:
Code: Select all
nuAddActionButton('filterDisplay', 'Show Only Display', 'nuSearchAction("display")');


But this doesn't:

Code: Select all
nuAddActionButton('filterDisplay', 'Show Only Display', 'nuSearchAction("", "display")');
Last edited by kev1n on Mon Sep 14, 2020 2:07 pm, edited 1 time in total.
kev1n
 
Posts: 1038
Joined: Mon Oct 15, 2018 2:13 am

Next

Return to General