number format on reports

Questions related to using nuBuilder Forte.

number format on reports

Postby paulkauz » Mon Nov 23, 2020 7:36 pm

Bildschirmfoto 2020-11-23 um 10.57.04.png
Format chosen on report builder
Bildschirmfoto 2020-11-23 um 10.57.04.png (158.68 KiB) Viewed 243 times


Bildschirmfoto 2020-11-23 um 10.57.55.png
Bildschirmfoto 2020-11-23 um 10.57.55.png (42.34 KiB) Viewed 243 times


The number formats do not work on reports.
If you like nuBuilder, please leave a review on SourceForge
paulkauz
 
Posts: 30
Joined: Sat Oct 31, 2020 3:38 am

Re: number format on reports

Postby Celson » Wed Nov 25, 2020 4:16 am

I am facing the same problem:

Report Designer
NumberFormatReport2.png
NumberFormatReport2.png (33.52 KiB) Viewed 235 times


Form with Subform
NumberFormatReport3.png
NumberFormatReport3.png (46.47 KiB) Viewed 234 times


PDF Printed
NumberFormatReport4.png
NumberFormatReport4.png (61.95 KiB) Viewed 234 times
Celson
 
Posts: 36
Joined: Wed Jan 27, 2016 9:05 pm

Re: number format on reports

Postby kev1n » Wed Nov 25, 2020 4:03 pm

Celson, if I understand correctly, you issue is that decimals are not being shown in the report and Paul's issue is that numbers are not grouped by thousands, right?
If you like nuBuilder, please leave a review on SourceForge

nuBuilder Code Library (85)
Installation Guides
Updating nuBuilder

Join Discord to talk about nuBuilder!
kev1n
nuBuilder Team
 
Posts: 1193
Joined: Mon Oct 15, 2018 2:13 am

Re: number format on reports

Postby paulkauz » Wed Nov 25, 2020 4:34 pm

Right
If you like nuBuilder, please leave a review on SourceForge
paulkauz
 
Posts: 30
Joined: Sat Oct 31, 2020 3:38 am

Re: number format on reports

Postby Celson » Wed Nov 25, 2020 7:36 pm

kev1n wrote:Celson, if I understand correctly, you issue is that decimals are not being shown in the report and Paul's issue is that numbers are not grouped by thousands, right?


Yes! My issue have to do with
1. Decimals are not being shown
2. Negative numbers are being formatted incorrectly (grouping signal appears before the minus signal) (see calc field on edit screen)
Celson
 
Posts: 36
Joined: Wed Jan 27, 2016 9:05 pm

Re: number format on reports

Postby admin » Thu Nov 26, 2020 5:12 am

People,

I believe I have fixed one formatting issue (not the minus bit yet)

It is on Github.

Please test it.


Steven
admin
Site Admin
 
Posts: 3404
Joined: Mon Jun 15, 2009 9:53 am

Re: number format on reports

Postby paulkauz » Thu Nov 26, 2020 5:03 pm

Hi Steven
Unfortunately the FIX does not work for me, or I have made something wrong.
I made a complete new install with the zip download from Github, but not the new, nor the previous formats do work on reports.
A format without decimals I can not even select in the report builder.

BR
Paul
If you like nuBuilder, please leave a review on SourceForge
paulkauz
 
Posts: 30
Joined: Sat Oct 31, 2020 3:38 am

Re: number format on reports

Postby Celson » Thu Nov 26, 2020 9:05 pm

Hi, Steven,

I have the same result as Paul, unfortunately!

Now, pehaps I am using the wrong zip. See snapshot (my annotations) below:
{F615AAA3-3947-401C-9131-4D0CA7FF0838}.png
{F615AAA3-3947-401C-9131-4D0CA7FF0838}.png (38.31 KiB) Viewed 179 times
Celson
 
Posts: 36
Joined: Wed Jan 27, 2016 9:05 pm

Re: number format on reports

Postby kev1n » Thu Nov 26, 2020 9:11 pm

https://github.com/steven-copley/nubuil ... master.zip is correct, it contains the latest files.
If you like nuBuilder, please leave a review on SourceForge

nuBuilder Code Library (85)
Installation Guides
Updating nuBuilder

Join Discord to talk about nuBuilder!
kev1n
nuBuilder Team
 
Posts: 1193
Joined: Mon Oct 15, 2018 2:13 am

Re: number format on reports

Postby Celson » Thu Nov 26, 2020 9:52 pm

Thank you, kev1n

Well, so the fix failed, isn´t it?
Celson
 
Posts: 36
Joined: Wed Jan 27, 2016 9:05 pm

Next

Return to General