Page 1 of 1

is PHP v7.2 now supported ? earlier versions security flaw

PostPosted: Fri Jan 04, 2019 11:55 pm
by bmullan
I seem to remember when reading thru the forum as I initially started with Nubuilder seeing messages that you couldn't use PHP v 7.2 with Nubuilder yet.

I just read that PHP Developers are pushing everyone to move/upgrade to PHP v7.2 because of security flaw in prior versions that expose http headers.

read here: https://twitter.com/DevaOnBreaches/stat ... 4524438528

So just wanted to check with the NuBuilder developers.

thanks
brian

Re: is PHP v7.2 now supported ? earlier versions security fl

PostPosted: Sat Jan 05, 2019 12:48 am
by kev1n

Re: is PHP v7.2 now supported ? earlier versions security fl

PostPosted: Sat Jan 05, 2019 6:05 am
by Janusz
I was testing on my data base PHP7.0, PHP7.2 and PHP7.3.
Currently I use PHP7.3 (Debian Stretch) and everything works fine and much faster than PHP7.0.

There are warnings with phpMyAdmin - but generally it concerns all php version - but all general functions are working OK.

What I observed the Export option for backup from phpMyAdmin is not credible - it exports the .sql file - but if you would like to import it back - very often it is not working !!!
So now for export I use only command line - something like this:

mysqldump -u root -p DBname > /xxxx/temp/DBnamecopy.sql

and files generated this way so far were always OK and you can import it with phpMyAdmin.


additionally to eliminate some errors on Linux with phpMyAdmin (both 7.2 and 7.3) please follow:
https://devanswers.co/problem-php-7-2-p ... sql-count/

Re: is PHP v7.2 now supported ? earlier versions security fl

PostPosted: Sun Jan 06, 2019 6:10 am
by ARWEN
Thank you Janusz for your advice !