Win10 installation

Questions related to using nuBuilder Forte.

Win10 installation

Postby Janusz » Sun Jan 13, 2019 11:16 pm

Hi,
Normally I am running nuBuilder on my Debian Stretch virtual server and it works fine.
Just to test some options I was trying to install nuBuilder on Win10 with following configuration:
Apache 2.4, PHP 7.3. (all latest releases). I did copy of my mySql data base from linux to mySql on PC.

When I launch nuBuilder so after login I get following errors.

Did anyone experieced similar issue?

https://drive.google.com/open?id=1Y2mmK ... 3gabzwZ4Or

and some logs from zzzzsys_debug

Code: Select all
2019-01-13 14:22:38 - SQL Error in <b>nuRunQuery</b>

<br>

[0] :
===USER==========

globeadmin

===PDO MESSAGE===

SQLSTATE[HY000]: General error: 1364 Field 'sss_time' doesn't have a default value

===SQL===========

INSERT INTO zzzzsys_session SET sss_access = ?, zzzzsys_session_id = ?

===BACK TRACE====

C:\Apache24\htdocs\nuprocesslogins.php - line 107 (nuRunQuery)

C:\Apache24\htdocs\nusession.php - line 22 (nuLoginSetupGlobeadmin)

C:\Apache24\htdocs\nuapi.php - line 6 (require_once)
Janusz
 
Posts: 229
Joined: Fri Dec 28, 2018 10:11 pm
Location: Krakow, Poland

Re: Win10 installation

Postby Janusz » Sun Jan 13, 2019 11:38 pm

FYI
I checked with original nubuilder4.sql file and it works,
So maybe some issues with data transfer or some specific notation between linux and windows (when you transfer full application)
Janusz
 
Posts: 229
Joined: Fri Dec 28, 2018 10:11 pm
Location: Krakow, Poland

Re: Win10 installation

Postby kev1n » Mon Jan 14, 2019 12:17 am

kev1n
 
Posts: 266
Joined: Mon Oct 15, 2018 2:13 am

Re: Win10 installation

Postby Janusz » Mon Jan 14, 2019 5:32 am

Thanks for your feedback.
With STRICT_TRANS_TABLES - disabled it goes just few steps more.
https://drive.google.com/open?id=15lcGg ... 5-pQLGJz5D
https://drive.google.com/open?id=1ejE2r ... 55lHZ7YV7Q

From my side if there is no quick solution - so no need to investigate more.

some backgroung and other observations:
Why I was checking this. I am keeping one old laptop with linux as back-up in case the virtual server is down or crashed - so then locally I can continue to work with last back-up (and it works perfectly - no problem with data transfer, just a litle bit slower in operation - old Intel Atom N270 :-) ).

Instead of that old laptop with Linux I wanted to use one of my PC as local server, but it looks that such soulution is not working properly when transfering from linux to PC.
Regarding data tranfer between mysql from Linux to PC no errors are reported. All tables when checking with phpmyAdmin on PC are OK.
The transfer I am doing is on mysql command line level as phpmyadmin is changing views to regular tables.

I checked once again on my PC/Win10 the original fresh instalation of nuBuilder and it shows only the first page nearly OK - if you click any button than its like that:
https://drive.google.com/open?id=1u_Kxc ... rE2Es-gAYR
Janusz
 
Posts: 229
Joined: Fri Dec 28, 2018 10:11 pm
Location: Krakow, Poland


Return to General