iframe lag

Questions related to using nuBuilder Forte.

iframe lag

Postby Janusz » Fri Feb 15, 2019 6:45 pm

Hi,
I am using some forms placed inside the Run/iframes.
In such cases I am experiencing short lag (1 or 2 sec) until the form is fully opened.
For all other cases the lag is practically not visible - it concerns only iframes.

It's not big issue but - I am curious if you are observing similar behaviour or maybe there some trics to minimise such lag.

Please find enclosed short movie showing the lag (2 iframes on main panel - and by purposed the video has poor quality)
https://drive.google.com/open?id=17qlJ4 ... cakZMRRSgM
Janusz
 
Posts: 260
Joined: Fri Dec 28, 2018 10:11 pm
Location: Krakow, Poland

Re: iframe lag

Postby kev1n » Fri Feb 15, 2019 11:20 pm

I've noticed that, too. An embedded browse form loads noticeably slower than one that is not embedded. But the delay is usually less than one second, though sometimes it takes longer. A browse-only form loads almost instantly (maybe < 0.2 s).

0.1 second is about the limit for having the user feel that the system is reacting instantaneously [...]
1.0 second is about the limit for the user's flow of thought to stay uninterrupted, even though the user will notice the delay. [...] but the user does lose the feeling of operating directly on the data.

https://www.nngroup.com/articles/respon ... nt-limits/
kev1n
 
Posts: 364
Joined: Mon Oct 15, 2018 2:13 am

Re: iframe lag

Postby Janusz » Sat Feb 16, 2019 6:11 am

Hi,
Is it possible in the nuBuilder to implement delay for some iframes loading ?

I have several tabs in my application with iframes - and wanted to make one tab to be loaded first and later for example after 1 sec to start process of loading iframes in the remaing tabs.

I noticed such approach on some forums for web page speed optimisation. So far I did not succeed with nuDisable for example or similar functions,

If you would have some ideas how to do it I would appreciate it very much.
Janusz
 
Posts: 260
Joined: Fri Dec 28, 2018 10:11 pm
Location: Krakow, Poland

Re: iframe lag

Postby kev1n » Sun Feb 17, 2019 12:42 am

I don't think that's easy to do. At least not without changing the core functionality.
kev1n
 
Posts: 364
Joined: Mon Oct 15, 2018 2:13 am


Return to General