Error calculating sum

Questions related to nuBuilder Forte Reports and the Report Builder.

Error calculating sum

Postby treed » Wed Dec 23, 2020 5:10 am

I put together a nice invoice report and when the total is summed I get the following debug error. The field I'm trying to sum is OrdLineAmt.

[0] :
===USER==========

globeadmin

===PDO MESSAGE===

SQLSTATE[42S02]: Base table or view not found: 1146 Table 'WCBBQ_DB.___nu15fe249fd7f33e____nu_summary' doesn't exist

===SQL===========

SELECT SUM(nu_sum_OrdLineAmt) AS the_sum_a FROM ___nu15fe249fd7f33e____nu_summary

===BACK TRACE====

/var/www/html/db/nurunpdf.php - line 756 (nuRunQuery)

/var/www/html/db/nurunpdf.php - line 604 (nuGetFieldValue)

/var/www/html/db/nurunpdf.php - line 370 (getObjectRows)

/var/www/html/db/nurunpdf.php - line 320 (setObjectLines)

/var/www/html/db/nurunpdf.php - line 256 (buildSection)

/var/www/html/db/nurunpdf.php - line 48 (nuBuildReport)
treed
 
Posts: 81
Joined: Mon May 18, 2020 7:32 am

Re: Error calculating sum

Postby treed » Tue Dec 29, 2020 10:22 am

After doing some research it seems its documented in v.3 that a grouping is needed to have a some. I'll assume that's the issue as I've worked around it another way. If this is correct, perhaps a future version could pass that info along in an error message.
treed
 
Posts: 81
Joined: Mon May 18, 2020 7:32 am

Re: Error calculating sum

Postby steven » Wed Dec 30, 2020 7:31 am

treed,

That sounds right.

The Report Builder works the same as v3.

Steven
steven
 
Posts: 107
Joined: Mon Jun 15, 2009 5:33 pm


Return to Reports