HTTP ERROR 500

Questions related to nuBuilder Forte Reports and the Report Builder.

HTTP ERROR 500

Postby marcvander » Fri May 11, 2018 10:11 pm

Hey,

I had reports in nuBuilder v3. I transferred them to my v4, keeping rse_layout and adding a Table with the SQL builder. When I run the report in v4 (which worked well in v3), I have an HTTP ERROR 500:

Capture d’écran 2018-05-11 à 14.34.38.png
Capture d’écran 2018-05-11 à 14.34.38.png (126.29 KiB) Viewed 1657 times


Where could this come from?

Thanks
Config:
nuBuilder v4 on a dedicated LAMP server:
-Ubuntu 14.04.5 LTS
-Apache 2.4.7
-MySQL 14.14 Distrib 5.7.22
-PHP 5.5.9-1ubuntu4.23
marcvander
 
Posts: 101
Joined: Tue Mar 27, 2018 1:27 am

Re: HTTP ERROR 500

Postby toms » Fri May 11, 2018 11:22 pm

Salut,

Is there an error/details in the nuDebug results?
toms
 

Re: HTTP ERROR 500

Postby marcvander » Sat May 12, 2018 12:18 am

Where can I see the nuDebug results ? How does it work ?
Config:
nuBuilder v4 on a dedicated LAMP server:
-Ubuntu 14.04.5 LTS
-Apache 2.4.7
-MySQL 14.14 Distrib 5.7.22
-PHP 5.5.9-1ubuntu4.23
marcvander
 
Posts: 101
Joined: Tue Mar 27, 2018 1:27 am

Re: HTTP ERROR 500

Postby toms » Sat May 12, 2018 12:59 am

In the top right hand corner, there's an options menu.

IMG_20180511_172455.png
IMG_20180511_172455.png (107.24 KiB) Viewed 1648 times


..
toms
 

Re: HTTP ERROR 500

Postby marcvander » Sat May 12, 2018 1:49 am

Ok thanks. Here is the list of errors:

Capture d’écran 2018-05-11 à 18.18.18.png
Capture d’écran 2018-05-11 à 18.18.18.png (309.35 KiB) Viewed 1645 times


Only the first line seems relevant. RECHERCHEPOINTAGE is my launch form for the report:

Capture d’écran 2018-05-11 à 18.15.55.png
Capture d’écran 2018-05-11 à 18.15.55.png (57.87 KiB) Viewed 1645 times
Config:
nuBuilder v4 on a dedicated LAMP server:
-Ubuntu 14.04.5 LTS
-Apache 2.4.7
-MySQL 14.14 Distrib 5.7.22
-PHP 5.5.9-1ubuntu4.23
marcvander
 
Posts: 101
Joined: Tue Mar 27, 2018 1:27 am

Re: HTTP ERROR 500

Postby toms » Sat May 12, 2018 1:57 am

Do you use custom PHP/javascript?
toms
 

Re: HTTP ERROR 500

Postby marcvander » Sat May 12, 2018 1:58 am

After going over the launch form RECHERCHEPOINTAGE, I found an error in the table entered. So now I don't have any error anymore in nuDebug when I try to run the report. But I still have a HTTP ERROR 500. It seems more of an internal server error
Last edited by marcvander on Sat May 12, 2018 2:14 am, edited 1 time in total.
Config:
nuBuilder v4 on a dedicated LAMP server:
-Ubuntu 14.04.5 LTS
-Apache 2.4.7
-MySQL 14.14 Distrib 5.7.22
-PHP 5.5.9-1ubuntu4.23
marcvander
 
Posts: 101
Joined: Tue Mar 27, 2018 1:27 am

Re: HTTP ERROR 500

Postby marcvander » Sat May 12, 2018 1:59 am

No I don't use any PHP nor JS on this form
Config:
nuBuilder v4 on a dedicated LAMP server:
-Ubuntu 14.04.5 LTS
-Apache 2.4.7
-MySQL 14.14 Distrib 5.7.22
-PHP 5.5.9-1ubuntu4.23
marcvander
 
Posts: 101
Joined: Tue Mar 27, 2018 1:27 am

Re: HTTP ERROR 500

Postby toms » Sat May 12, 2018 2:06 am

I'm not familiar (yet) with nuBuilder's reporting engine. I'm afraid I can't help you with this.
toms
 

Re: HTTP ERROR 500

Postby marcvander » Sat May 12, 2018 2:13 am

Ok no worries, I'll wait for the admin to answer and see if we can find something
Config:
nuBuilder v4 on a dedicated LAMP server:
-Ubuntu 14.04.5 LTS
-Apache 2.4.7
-MySQL 14.14 Distrib 5.7.22
-PHP 5.5.9-1ubuntu4.23
marcvander
 
Posts: 101
Joined: Tue Mar 27, 2018 1:27 am

Next

Return to Reports