New Installation

Questions related to installing, setting up and configuring nuBuilder Forte

New Installation

Unread postby Abes » Fri Nov 26, 2021 12:28 am

Hi All - I am itching to try nuBuilder and have tried to install it, to no avail, and yes I have gone through the install guide(s) to the letter. First some info:

Using Windows 11
WAMP server running on local machine (localhost, using port 7080)
Apache 2.4.46
PHP 7.3.21
MySQL 5.7.31
Created a "nubuilder4" database in mySQL via phpMyAdmin
I copied the nuBuilder installation files, as is, to "WAMP64/www/nubuilder4.5
Note: phpMyAdmin and PHPRunner both run without a problem on localhost:7080 so I don't think there is a problem with that.

I have done the following in nuconfig.php:

$nuConfigDBHost = "localhost:7080"; //-- Database Host / IP. You may try localhost if 127.0.0.1 does not work.
$nuConfigDBName = "nubuilder4"; //-- Database Name. You can change the name, if desired. The database must exist or must be created on your server.
$nuConfigDBUser = "root"; //-- Database User. Change the user, if desired. The user must exist or must be created.
$nuConfigDBPassword = "admin"; //-- Database Password. We recommend you to use any strong password.
//-- The default username for a new MySQL installation is root, with a blank password.

$nuConfigDBEngine = "InnoDB"; //-- InnoDB or MyISAM
$nuConfigDBCollate = "utf8mb4_unicode_ci"; //-- Or utf8_general_ci etc.
$nuConfigDBCharacterSet = "utf8mb4"; //-- Or utf8 etc.

// Administrator Login:
$nuConfigDBGlobeadminUsername = "*******"; //-- globeadmin username. You can choose any username you like.
$nuConfigDBGlobeadminPassword = "*******";

So what happens when I try to run "localhost:7080/nubuilder4.5" in my browser (Firefox) I get the following error:

"Connection failed: SQLSTATE[HY000] [2006] MySQL server has gone away"

mySQL has not timed out when I get this error as I can immediately access phpMyAdmin, and have also tried to stop and start WAMP and then try again, no luck.

I have added the tweaks to "my.ini" (key_buffer_size and max_allowed_packet) as described in the installation guide, also without any luck, and yes I did restart the server and browser after doing these adjustments.

What am I doing wrong, any help will be appreciated, thanks.
Abes
 
Posts: 2
Joined: Thu Nov 25, 2021 10:04 pm
nuBuilder Version: 4.5

Re: New Installation

Unread postby kev1n » Fri Nov 26, 2021 12:54 am

Hi,

Does this help'? “MySQL server has gone away” error – Solution(s)
https://haydenjames.io/mysql-server-has ... solutions/
kev1n
nuBuilder Team
 
Posts: 2117
Joined: Mon Oct 15, 2018 2:13 am
nuBuilder Version: 4.5

Re: New Installation

Unread postby kev1n » Fri Nov 26, 2021 1:19 am

Something else to try:

Remove the port number:
$nuConfigDBHost = "localhost"

And open the url like
Code: Select all
http://localhost:7080/nubuilder4
(replace nubuilder4 with your nubuilder folder name)
kev1n
nuBuilder Team
 
Posts: 2117
Joined: Mon Oct 15, 2018 2:13 am
nuBuilder Version: 4.5

Re: New Installation

Unread postby Abes » Fri Nov 26, 2021 2:13 am

Thanks guys - I applied both of your recommendations and it now works! In all honesty I wouldn't be able to say what made the difference but thanks nonetheless.
Abes
 
Posts: 2
Joined: Thu Nov 25, 2021 10:04 pm
nuBuilder Version: 4.5


Return to Installation

Who is online

Users browsing this forum: No registered users and 4 guests

cron