Report generates empty page

Report generates empty page

Postby johnbertell » Mon Dec 23, 2013 8:28 pm

Hi,
I am trying to build reports for my application but have struggled. Right now my nuBuilder only generates absolutely empty pages for the reports I built. I have tried installing the samplefinancial, and I get the same result on the reports which are there. When I press 'Print to screen' from the criteria form it generates an empty browser. The page source of the new browser page is completely empty. Exactly the same result from Print to PDF.
Anyone having a good idea where I should start troubleshooting?
John
johnbertell
 
Posts: 14
Joined: Thu Oct 24, 2013 2:02 pm

Re: Report generates empty page

Postby massiws » Tue Dec 24, 2013 12:09 pm

johnbertell, based on my experience, white pages often result from errors in PHP code.
Some suggestions:
  • are you sure about minimal resources required by nuBuilder? (see here);
  • are you sure your code in Report Builder is working right?
  • are you able to build the #dataTable# with all data you need on the report?

Max
massiws
 
Posts: 503
Joined: Thu May 24, 2012 9:38 am
Location: Milan, Italy

Re: Report generates empty page

Postby johnbertell » Tue Dec 24, 2013 10:07 pm

Thanks Max for quick response.
  • I have the min resources configured just like in the link you sent me
  • I am new to using the reports, so this was my first thought. That is why I installed the samplefinancial and tested the reports which exist there. And they produce the same result. Just for testing I made a very simple report with as little possibility for error as possible showing only one field and one label.
  • This is the php code for my simple test report:
Code: Select all
$str = "CREATE TABLE #dataTable# SELECT NOW() AS d ";
nuRunQuery($str);


I have tried to get the sql statement debugged there also, but it will not bring up the debug window.
John
johnbertell
 
Posts: 14
Joined: Thu Oct 24, 2013 2:02 pm

Re: Report generates empty page

Postby johnbertell » Wed Dec 25, 2013 9:30 pm

This seem to be the error. I get the same on two of my Linux machines (UBUNTU) but not on the third one.

Code: Select all
Wed Dec 25 13:54:08.310141 2013] [:error] [pid 22959] [client 10.102.164.74:44039] PHP Fatal error:  Cannot redeclare hex2bin() in /var/www/productionnu2/report_object.php on line 240, referer: http://10.64.0.115/productionnu2/form.php?x=1&f=run&r=152b98294d2234&dir=db/tankbulk&fly=&ses=152bac727e0e1f&BF=&newwin=0&historySession=152bac72aacef3&historyIndex=2&historyLocation=QnJvd3NlfHx8UnVuIEFjdGl2aXR5|||aHR0cDovLzEwLjY0LjAuMTE1L3Byb2R1Y3Rpb25udTIvYnJvd3NlLnBocD94PTEmcD0xJmY9cnVuJnM9Jm51b3BlbmVyPTE1MmJhYzcyYWE2NDNjJnByZWZpeD0mZGlyPWRiL3RhbmtidWxrJnNlcz0xNTJiYWM3MjdlMGUxZiZmb3JtX3Nlcz0mbG9va3VwX2NvZGU9Jmhpc3RvcnlTZXNzaW9uPTE1MmJhYzcyYWFjZWYzJmhpc3RvcnlJbmRleD0xJmhpc3RvcnlMb2NhdGlvbj1mSHg4U0U5TlJRPT18fHxhSFIwY0Rvdkx6RXdMalkwTGpBdU1URTFMM0J5YjJSMVkzUnBiMjV1ZFRJdlptOXliUzV3YUhBL2VEMHhKbVk5YVc1a1pYZ21jajB0TVNaa2FYSTlaR0l2ZEdGdWEySjFiR3NtYzJWelBURTFNbUpoWXpjeU4yVXdaVEZtSm5SaFlqMHomdGFiPTA=


John
johnbertell
 
Posts: 14
Joined: Thu Oct 24, 2013 2:02 pm

Re: Report generates empty page

Postby johnbertell » Wed Dec 25, 2013 9:47 pm

Now got it fixed, here is the solution. Appearently a problem everyone with PHP 5.4 or newer versions will have.
http://forums.nubuilder.com/viewtopic.php?f=4&t=8158&p=11827&hilit=hex2bin+#p11827
John
johnbertell
 
Posts: 14
Joined: Thu Oct 24, 2013 2:02 pm

Re: Report generates empty page

Postby massiws » Thu Dec 26, 2013 4:30 am

John, sorry for delay: are your reports working fine now?
massiws
 
Posts: 503
Joined: Thu May 24, 2012 9:38 am
Location: Milan, Italy

Re: Report generates empty page

Postby johnbertell » Fri Dec 27, 2013 6:56 am

Yes, thank you Max. With this fix they work fine.
John
johnbertell
 
Posts: 14
Joined: Thu Oct 24, 2013 2:02 pm

Re: Report generates empty page

Postby massiws » Fri Dec 27, 2013 8:59 am

.
massiws
 
Posts: 503
Joined: Thu May 24, 2012 9:38 am
Location: Milan, Italy


Return to Report Writer